[packages_10.03.1] collectd: backport r29404
[openwrt/svn-archive/archive.git] / utils / lilo / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 90492a7..35f6da5
@@ -1,50 +1,53 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4091 2006-06-27 00:35:46Z mbm $
-#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lilo
-PKG_VERSION:=22.7.2
-PKG_RELEASE:=1
+PKG_VERSION:=22.8
+PKG_RELEASE:=2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
-PKG_MD5SUM:=
-PKG_CAT:=zcat
+PKG_MD5SUM:=72765f2aafd20e23ecf07ebd22baeec7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lilo
-SECTION:=base
-CATEGORY:=Boot Loaders
-TITLE:=lilo
-DESCRIPTION:=lilo
-URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
-DEPENDS:=@LINUX_2_6_X86||LINUX_2_4_X86
+  SECTION:=base
+  CATEGORY:=Boot Loaders
+  DEPENDS:=@TARGET_x86
+  TITLE:=lilo
+  URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
 endef
 
-
-
+define Package/lilo/conffiles
+/etc/lilo.conf
+endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) alles
-       $(STRIP) $(PKG_BUILD_DIR)/lilo.static
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(HOSTCC) -m32" \
+               alles
 endef
 
 define Package/lilo/install
-       mkdir -p $(1)/sbin
-       mkdir -p $(1)/etc/init.d
-       mkdir -p $(1)/boot
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_BUILD_DIR)/lilo.static $(1)/sbin/lilo
-       $(CP) lilo.conf $(1)/etc
-       $(CP) boot.msg $(1)/etc
-       #$(CP) S11Pivot $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) ./files/lilo.conf $(1)/etc/
+       $(CP) ./files/boot.msg $(1)/etc/
 endef
 
+$(foreach command, as86 ld86, \
+  $(eval $(call RequireCommand,$(command), \
+   $(PKG_NAME) requires $(command). \
+  )) \
+)
+
 $(eval $(call BuildPackage,lilo))
+