Update lilo to 22.8 (#3685)
[openwrt/svn-archive/archive.git] / utils / lilo / Makefile
index 77a45b7c29879fde718e6a1a365577a736db6937..44264f48f386bf726529f8a02489381d68793f00 100644 (file)
@@ -4,26 +4,24 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4091 2006-06-27 00:35:46Z mbm $
-#
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lilo
-PKG_VERSION:=22.7.3
+PKG_VERSION:=22.8
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
-PKG_MD5SUM:=
-PKG_CAT:=zcat
+PKG_MD5SUM:=72765f2aafd20e23ecf07ebd22baeec7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lilo
   SECTION:=base
   CATEGORY:=Boot Loaders
-  DEPENDS:=@LINUX_2_6_X86||LINUX_2_4_X86
+  DEPENDS:=@TARGET_x86
   TITLE:=lilo
   URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
 endef
@@ -34,15 +32,20 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) alles
-       $(STRIP) $(PKG_BUILD_DIR)/lilo.static
 endef
 
 define Package/lilo/install
-       install -d -m0755 $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_BUILD_DIR)/lilo.static $(1)/sbin/lilo
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/lilo.conf $(1)/etc/
        $(CP) ./files/boot.msg $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,lilo))
+
+$(foreach command, as86 ld86, \
+  $(eval $(call RequireCommand,$(command), \
+   $(PKG_NAME) requires $(command). \
+  )) \
+)