remove useless xorg macros patch
[openwrt/svn-archive/archive.git] / utils / lilo / Makefile
index 3e7ce415c61bea2728389ce2fb35411af66973ad..c77e245fc91eb157a863220d3c96d9f46e17815d 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/lilo
   SECTION:=base
   CATEGORY:=Boot Loaders
-  DEPENDS:=@LINUX_2_6_X86||LINUX_2_4_X86
+  DEPENDS:=@LINUX_2_6_X86
   TITLE:=lilo
   URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
 endef
@@ -35,15 +35,20 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) alles
-       $(STRIP) $(PKG_BUILD_DIR)/lilo.static
 endef
 
 define Package/lilo/install
-       install -d -m0755 $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_BUILD_DIR)/lilo.static $(1)/sbin/lilo
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/lilo.conf $(1)/etc/
        $(CP) ./files/boot.msg $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,lilo))
+
+$(foreach command, as86 ld86, \
+  $(eval $(call RequireCommand,$(command), \
+   $(PKG_NAME) requires $(command). \
+  )) \
+)