[packages] flashrom: update source url, use PKG_INSTALL & MAKE_FLAGS, refresh patches
[openwrt/svn-archive/archive.git] / utils / lirc / Makefile
index 94794cc32995775cee7f314f4e4bf4519221f09e..5b71d1526863595adc5b9ea81454dc91a1de111c 100644 (file)
@@ -4,19 +4,20 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5624 2007-09-04 00:29:07Z Dottout $
 
 include $(TOPDIR)/rules.mk
 # we use the $LINUX_DIR variable, which is defined in kernel.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=lirc
-PKG_VERSION:=0.8.3
+PKG_VERSION:=0.8.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/${PKG_NAME}
-PKG_MD5SUM:=8e78eeded7b31e5ad02e328970437c0f
+PKG_MD5SUM:=fb1dcddbc8ca3d03c7f3a2d40cf28b71
+
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -100,11 +101,11 @@ CONFIGURE_ARGS += \
        --disable-nls \
        --disable-static \
        --with-kerneldir="$(LINUX_DIR)" \
-       --with-driver="mceusb2" \
+       --with-driver="mceusb" \
        --without-x \
        --with-pic \
        --with-gnu-ld \
-       --enable-sandboxed \
+       --enable-sandboxed
 
 define Package/lirc/conffiles
 /etc/lircd.conf
@@ -112,7 +113,7 @@ endef
 
 MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
-       all
+       ARCH="$(LINUX_KARCH)"
 
 define  Package/lirc/install
        $(INSTALL_DIR) $(1)/usr/sbin/