[PATCH] lm-sensors package upgrade/update
[openwrt/svn-archive/archive.git] / utils / lm-sensors / Makefile
index 46e5689d95145a328eb68879e77707c1e55cf811..66684ceb3e3a94f1ba4c8a112688debd088be97a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lm-sensors
-PKG_VERSION:=3.0.2
+PKG_VERSION:=3.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=lm_sensors-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://dl.lm-sensors.org/lm-sensors/releases/
-PKG_MD5SUM:=5b210ba9cc01f00161c438fd618484e5
+PKG_MD5SUM:=58a9a225808ac4587c4c8cbd12b40b5c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/lm_sensors-$(PKG_VERSION)
 
@@ -23,21 +23,21 @@ define Package/lm-sensors/Default
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=lm-sensors
-  DEPENDS:=+sysfsutils @LINUX_2_6
+  DEPENDS:=+sysfsutils
   URL:=http://www.lm-sensors.org/
 endef
 
 define Package/lm-sensors
   $(call Package/lm-sensors/Default)
-  TITLE+= (programs)
-  DEPENDS+= @TARGET_x86
+  TITLE+=(programs)
+  DEPENDS+=+libsensors
 endef
 
 define Package/libsensors
   $(call Package/lm-sensors/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE+= libraries
+  TITLE+=libraries
 endef
 
 define Package/lm-sensors/description
@@ -48,6 +48,10 @@ define Package/libsensors/description
        lm-sensors libraries
 endef
 
+define Package/lm-sensors/conffiles
+/etc/sensors.conf
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                KERNELVERSION="$(LINUX_VERSION)" \
@@ -61,10 +65,10 @@ endef
 
 define Package/lm-sensors/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/prog/sensors/sensors $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/prog/detect/sensors-detect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/sensors/sensors $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/detect/sensors-detect $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(CP) files/sensors.conf $(1)/etc/sensors.conf
+       $(INSTALL_CONF) ./files/sensors.conf $(1)/etc/sensors.conf
 endef
 
 define Package/libsensors/install