update tor to 0.2.0.9-alpha - includes transparent proxy support
[openwrt/svn-archive/archive.git] / utils / logrotate / Makefile
index 4d0f3cfcff78748a80c4f2d77656721659c3a31b..00366902a74a59d847d87905aa66d9f0639bb0cb 100644 (file)
@@ -19,7 +19,6 @@ PKG_SOURCE_URL:= \
        http://ftp.fr.debian.org/debian/pool/main/l/logrotate \
        http://ftp.us.debian.org/debian/pool/main/l/logrotate
 PKG_MD5SUM:=552639142e163745f6bcd4f1f3816d8a
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -31,22 +30,27 @@ define Package/logrotate
   CATEGORY:=Utilities
   DEPENDS:=+libpopt
   TITLE:=rotates, compresses, and mails system logs
-  DESCRIPTION:=\
-       logrotate is designed to ease administration of systems that generate \\\
-       large numbers of log files. It allows auto-matic rotation, compression, \\\
-       removal and mailing of log files. Each log file may be handled daily, \\\
-       weekly, monthly or when it grows too large.
   URL:=http://packages.debian.org/unstable/admin/logrotate
 endef
 
+define Package/logrotate/description
+       logrotate is designed to ease administration of systems that generate 
+       large numbers of log files. It allows auto-matic rotation, compression, 
+       removal and mailing of log files. Each log file may be handled daily, 
+       weekly, monthly or when it grows too large.
+endef
+
 define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               RPM_OPT_FLAGS="\$$$$(EXTRA_CFLAGS)" \
-               LDFLAGS="\$$$$(EXTRA_LDFLAGS)" \
+               RPM_OPT_FLAGS:="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
                logrotate \
        )
 endef