replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / utils / logrotate / Makefile
index 091e18302fdde5109b59b0c1c1d20f4daee1c260..4d0f3cfcff78748a80c4f2d77656721659c3a31b 100644 (file)
@@ -52,11 +52,11 @@ define Build/Compile
 endef
 
 define Package/logrotate/install       
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) ${PKG_BUILD_DIR}/logrotate $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/logrotate.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/logrotate.d
+       $(INSTALL_DIR) $(1)/etc/logrotate.d
 endef
 
 $(eval $(call BuildPackage,logrotate))