[packages] collectd: remove redundant build dependencies
[openwrt/svn-archive/archive.git] / utils / logrotate / Makefile
index 00366902a74a59d847d87905aa66d9f0639bb0cb..53ee7205944aedab33935a86bc2fadd450e393a2 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -20,9 +19,6 @@ PKG_SOURCE_URL:= \
        http://ftp.us.debian.org/debian/pool/main/l/logrotate
 PKG_MD5SUM:=552639142e163745f6bcd4f1f3816d8a
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/logrotate
@@ -44,8 +40,8 @@ define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
-EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-EXTRA_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
 
 define Build/Compile
        $(call Build/Compile/Default, \