[packages] collectd: remove redundant build dependencies
[openwrt/svn-archive/archive.git] / utils / logrotate / Makefile
index 4d0f3cfcff78748a80c4f2d77656721659c3a31b..53ee7205944aedab33935a86bc2fadd450e393a2 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,10 +18,6 @@ PKG_SOURCE_URL:= \
        http://ftp.fr.debian.org/debian/pool/main/l/logrotate \
        http://ftp.us.debian.org/debian/pool/main/l/logrotate
 PKG_MD5SUM:=552639142e163745f6bcd4f1f3816d8a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,22 +26,27 @@ define Package/logrotate
   CATEGORY:=Utilities
   DEPENDS:=+libpopt
   TITLE:=rotates, compresses, and mails system logs
-  DESCRIPTION:=\
-       logrotate is designed to ease administration of systems that generate \\\
-       large numbers of log files. It allows auto-matic rotation, compression, \\\
-       removal and mailing of log files. Each log file may be handled daily, \\\
-       weekly, monthly or when it grows too large.
   URL:=http://packages.debian.org/unstable/admin/logrotate
 endef
 
+define Package/logrotate/description
+       logrotate is designed to ease administration of systems that generate 
+       large numbers of log files. It allows auto-matic rotation, compression, 
+       removal and mailing of log files. Each log file may be handled daily, 
+       weekly, monthly or when it grows too large.
+endef
+
 define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               RPM_OPT_FLAGS="\$$$$(EXTRA_CFLAGS)" \
-               LDFLAGS="\$$$$(EXTRA_LDFLAGS)" \
+               RPM_OPT_FLAGS:="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
                logrotate \
        )
 endef