[patchteam] sysfsutils: separate libsysfs and sysfsutils and move to libs, add patch...
[openwrt/svn-archive/archive.git] / utils / logrotate / Makefile
index e6b81950bd0d9c3d7a258fbf5e19315ff65f6d17..8585c953654fa8bd8a94557dd86e3245ec343e03 100644 (file)
@@ -1,15 +1,14 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=logrotate
-PKG_VERSION:=3.7.1
+PKG_VERSION:=3.7.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
@@ -18,11 +17,7 @@ PKG_SOURCE_URL:= \
        http://ftp.debian.org/debian/pool/main/l/logrotate \
        http://ftp.fr.debian.org/debian/pool/main/l/logrotate \
        http://ftp.us.debian.org/debian/pool/main/l/logrotate
-PKG_MD5SUM:=552639142e163745f6bcd4f1f3816d8a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=b3589bea6d8d5afc8a84134fddaae973
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,20 +26,22 @@ define Package/logrotate
   CATEGORY:=Utilities
   DEPENDS:=+libpopt
   TITLE:=rotates, compresses, and mails system logs
-  DESCRIPTION:=\
-       logrotate is designed to ease administration of systems that generate \\\
-       large numbers of log files. It allows auto-matic rotation, compression, \\\
-       removal and mailing of log files. Each log file may be handled daily, \\\
-       weekly, monthly or when it grows too large.
   URL:=http://packages.debian.org/unstable/admin/logrotate
 endef
 
+define Package/logrotate/description
+       logrotate is designed to ease administration of systems that generate 
+       large numbers of log files. It allows auto-matic rotation, compression, 
+       removal and mailing of log files. Each log file may be handled daily, 
+       weekly, monthly or when it grows too large.
+endef
+
 define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
-EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-EXTRA_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
 
 define Build/Compile
        $(call Build/Compile/Default, \
@@ -56,9 +53,9 @@ endef
 
 define Package/logrotate/install       
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) ${PKG_BUILD_DIR}/logrotate $(1)/usr/sbin/
+       $(INSTALL_BIN) ${PKG_BUILD_DIR}/logrotate $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(CP) ./files/logrotate.conf $(1)/etc/
+       $(INSTALL_DATA) ./files/logrotate.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/logrotate.d
 endef