add libtool fixes, cleanup
[openwrt/svn-archive/archive.git] / utils / logrotate / Makefile
index 51f8380317ab6ba5fc763d8de540787b0cbddfe2..e6b81950bd0d9c3d7a258fbf5e19315ff65f6d17 100644 (file)
@@ -43,9 +43,12 @@ define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               RPM_OPT_FLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
+               RPM_OPT_FLAGS:="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
                logrotate \
        )