rdiff-backup: move to the utils section (patch by edgar soldin)
[openwrt/svn-archive/archive.git] / utils / lrzsz / Makefile
index 8fff61888f15d3407f575a98de86125c4e4c3ebf..7c554b2b2f14ea2858a645d78a941047c9f6977b 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.ohse.de/uwe/releases/
 PKG_MD5SUM:=b5ce6a74abc9b9eb2af94dffdfd372a4
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +21,16 @@ define Package/lrzsz
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=X,Y and Z-modem protocols
-  DESCRIPTION:=\
-       Transfer files in your login sessions.\\\
-       Very leightweight and straight forward.\\\
-       You just need a terminal client that can do \\\
-       either X, Y or Z-modem file transfers.
   URL:=http://www.ohse.de/uwe/software/lrzsz.html
 endef
 
+define Package/lrzsz/description
+       Transfer files in your login sessions.
+       Very leightweight and straight forward.
+       You just need a terminal client that can do 
+       either X, Y or Z-modem file transfers.
+endef
+
 # uses GNU configure
 
 define Build/Compile   
@@ -43,9 +40,9 @@ define Build/Compile
 endef
 
 define Package/lrzsz/install   
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/lrz $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/lsz $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lrz $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lsz $(1)/usr/bin/
        (cd $(1)/usr/bin; \
                ln -fs lrz lrx; \
                ln -fs lrz lrb; \