more package submenus
[openwrt/svn-archive/archive.git] / utils / mc / Makefile
index bad97d3d377007809a13923961e74d3e1009f72a..2ba468ad85916ea61c4d092b3a68b5b5f0c30b3b 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
 PKG_VERSION:=4.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/
@@ -24,8 +24,19 @@ define Package/mc
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+glib1 +libncurses
-  TITLE:=Midnight Commander 4.1.X-MP
+  TITLE:=midnight commander - a powerful file manager
   URL:=http://www.ibiblio.org/mc/
+  SUBMENU:=filemanager
+endef
+
+define Package/mc/description
+       GNU Midnight Commander is a text-mode full-screen file manager. 
+       It uses a two panel interface and a subshell for command execution. 
+       It includes an internal editor with syntax highlighting and an 
+       internal viewer with support for binary files. Also included is 
+       Virtual Filesystem (VFS), that allows files on remote systems 
+       (e.g. FTP, SSH, SMB servers) and files inside archives to be 
+       manipulated like real files.
 endef
 
 CONFIGURE_ARGS += \