[packages] usb-modeswitch-data: only offer this package if usb-modeswitch has been...
[openwrt/svn-archive/archive.git] / utils / mc / Makefile
index f688d218b3e5f27661a060266afa91672836c323..93b8afc8cedd819a52259c715430e20a40a1b437 100644 (file)
@@ -1,22 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
-PKG_VERSION:=4.6.1
+PKG_VERSION:=4.6.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/
-PKG_MD5SUM:=18b20db6e40480a53bac2870c56fc3c4
-
-PKG_BUILD_DEPENDS:=glib1 libncurses
+PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
+PKG_MD5SUM:=ec92966f4d0c8b50c344fe901859ae2a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,20 +22,21 @@ define Package/mc
   CATEGORY:=Utilities
   DEPENDS:=+glib1 +libncurses
   TITLE:=midnight commander - a powerful file manager
-  DESCRIPTION:=\
-       GNU Midnight Commander is a text-mode full-screen file manager. \\\
-       It uses a two panel interface and a subshell for command execution. \\\
-       It includes an internal editor with syntax highlighting and an \\\
-       internal viewer with support for binary files. Also included is \\\
-       Virtual Filesystem (VFS), that allows files on remote systems \\\
-       (e.g. FTP, SSH, SMB servers) and files inside archives to be \\\
+  URL:=http://www.midnight-commander.org/
+  SUBMENU:=filemanager
+endef
+
+define Package/mc/description
+       GNU Midnight Commander is a text-mode full-screen file manager. 
+       It uses a two panel interface and a subshell for command execution. 
+       It includes an internal editor with syntax highlighting and an 
+       internal viewer with support for binary files. Also included is 
+       Virtual Filesystem (VFS), that allows files on remote systems 
+       (e.g. FTP, SSH, SMB servers) and files inside archives to be 
        manipulated like real files.
-  URL:=http://www.ibiblio.org/mc/
 endef
 
 CONFIGURE_ARGS += \
-       --prefix=/usr \
-       --disable-nls \
        --with-included-gettext \
        --with-ncurses \
        --without-sco \
@@ -64,13 +62,22 @@ CONFIGURE_ARGS += \
        --disable-glibtest \
        --with-glib12 \
        --with-glib-prefix="$(STAGING_DIR)/usr" \
-       , \
-       PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
+
+
+AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
+
+define Build/Prepare
+       $(Build/Prepare/Default)
+       for script in config.guess config.sub depcomp install-sh missing; do \
+               rm -f $(PKG_BUILD_DIR)/config/$$$$script; \
+               ln -s $(AM_HOST)/$$$$script $(PKG_BUILD_DIR)/config/$$$$script; \
+       done
+endef
 
 define Package/mc/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
-       ln -sf mc $(1)/usr/bin/mcedit
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
+       ln -nsf mc $(1)/usr/bin/mcedit
 endef
 
 $(eval $(call BuildPackage,mc))