replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / utils / mgetty / Makefile
index 100a1260dc4d3d5d850f7ba70c07c1170f16442d..221a6c5ebdf280af6fcaeb664ce3f94b393dec49 100644 (file)
@@ -92,8 +92,8 @@ define Build/Compile
 endef
 
 define Package/mgetty/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 \
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/faxq \
                $(PKG_INSTALL_DIR)/usr/bin/faxrm \
                $(PKG_INSTALL_DIR)/usr/bin/faxrunq \
@@ -103,13 +103,13 @@ define Package/mgetty/install
                $(PKG_INSTALL_DIR)/usr/bin/pbm2g3 \
                $(PKG_INSTALL_DIR)/usr/bin/sff2g3 \
                $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 \
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/sbin/mgetty \
                $(PKG_INSTALL_DIR)/usr/sbin/sendfax \
                $(PKG_INSTALL_DIR)/usr/sbin/faxrunqd \
                $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/lib/mgetty+sendfax
+       $(INSTALL_DIR) $(1)/usr/lib/mgetty+sendfax
        install -m4755 \
                $(PKG_INSTALL_DIR)/usr/lib/mgetty+sendfax/faxq-helper \
                $(1)/usr/lib/mgetty+sendfax/
@@ -117,7 +117,7 @@ define Package/mgetty/install
                $(PKG_INSTALL_DIR)/usr/lib/mgetty+sendfax/cour25n.pbm \
                $(PKG_INSTALL_DIR)/usr/lib/mgetty+sendfax/cour25.pbm \
                $(1)/usr/lib/mgetty+sendfax/
-       install -d -m0755 $(1)/etc/mgetty+sendfax
+       $(INSTALL_DIR) $(1)/etc/mgetty+sendfax
        install -m600 \
                $(PKG_INSTALL_DIR)/etc/mgetty+sendfax/dialin.config \
                $(PKG_INSTALL_DIR)/etc/mgetty+sendfax/faxheader \