[package] add sg3-utils (#1754)
[openwrt/svn-archive/archive.git] / utils / minicom / Makefile
index db748e704fa4aa1127d677113dde622ad5d2a5a2..49ddc14dc5f8622a4bbe4c66d2ea8c885dd2a413 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=minicom
-PKG_VERSION:=2.2-rc2
+PKG_VERSION:=2.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://alioth.debian.org/download.php/1721/
-PKG_MD5SUM:=c64c9ef958e91c00ca1cf2a7bc0db1f3
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://alioth.debian.org/download.php/2332/
+PKG_MD5SUM:=0ebe7a91898384ca906787cc4e2c3f25
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,17 +26,13 @@ define Package/minicom
   DEPENDS:=+libncurses
   TITLE:=Terminal emulation program
   URL:=http://alioth.debian.org/projects/minicom/
-endef
-
-# uses GNU configure
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
+  SUBMENU:=terminal
 endef
 
 define Package/minicom/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/minicom $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ascii-xfr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,minicom))