update mksh to R29c
[openwrt/svn-archive/archive.git] / utils / mksh / Makefile
index 9206c1e..2d0ad6e 100644 (file)
@@ -1,19 +1,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mksh
-PKG_VERSION:=R29b
+PKG_VERSION:=R29c
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).cpio.gz
 PKG_SOURCE_URL:=http://www.mirbsd.org/MirOS/dist/mir/mksh
-PKG_MD5SUM:=a21850403bd30bab461f2fc9f9b803b8
+PKG_MD5SUM:=183957bfcbf7ca212843d6ca85be2fce
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/package.mk
 
 # This program seems to depend on libssp, but only for GCC 4
-GCCVER:=$(if $(DUMP),4,$(word 1,$(subst ., ,$(CONFIG_GCC_VERSION))))
+GCCVER:=$(if $(DUMP),4,$(word 1,$(subst ., ,$(subst ",,$(CONFIG_GCC_VERSION)))))
+#"))))
 ifeq ($(GCCVER),4)
   DEP:=+libssp
 else
@@ -30,8 +31,8 @@ endef
 
 define Build/Compile
        cd $(PKG_BUILD_DIR); \
-               CC=$(TARGET_CC) \
-               TARGET_OS=$(shell uname -s) \
+               CC="$(TARGET_CC)" \
+               TARGET_OS="$(shell uname -s)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-DMKSH_SMALL=1" \
                LDFLAGS="$(TARGET_LDFLAGS)" \