Add a default configuration file (#1404)
[openwrt/svn-archive/archive.git] / utils / mutt / Makefile
index 87c0b87de8fbc5d8d93f286899eff49e9365609f..8528b36390f496512e7df16fe473a929f7fbb30f 100644 (file)
@@ -25,9 +25,8 @@ define Package/mutt
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl +libncurses
-  TITLE:=console mail client
-  DESCRIPTION:=Mail client for the text console
-  URL:=http://www.mutt.org
+  TITLE:=Console mail client
+  URL:=http://www.mutt.org/
 endef
 
 define Build/Configure
@@ -40,9 +39,13 @@ define Build/Configure
        )
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
 define Package/mutt/install
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/mutt $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,mutt))