[package] update nano to 2.1.9 (#4846)
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index fd678c504afad9fb298f553ba9a8c42cbad88165..020d550a751752e5c6199d55806354bb6064bb76 100644 (file)
@@ -1,24 +1,19 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=1.3.8
+PKG_VERSION:=2.1.9
 PKG_RELEASE:=1
-PKG_MD5SUM:=20633397bf5d462255f37dfcc7cad4e7
 
-PKG_SOURCE_URL:=http://www.ewtoo.org/~astyanax/nano/dist/v1.3 \
-       http://www.nano-editor.org/dist/v1.3
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.1
+PKG_MD5SUM:=41e9ffb4a055eba666cdb17c4e50ba21
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,32 +22,27 @@ define Package/nano
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
-  DESCRIPTION:=GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone of the Pico text editor..
   URL:=http://www.nano-editor.org/
+  SUBMENU:=Editors
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                        --disable-static \
-                        --with-gnu-ld \
-                        --disable-rpath \
-                        --enable-tiny \
-                        --disable-glibtest \
-                        --disable-utf8 \
-                        --without-slang,ac_cv_header_regex_h=no)
+define Package/nano/description
+       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
+       of the Pico text editor..
 endef
 
-define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --enable-tiny \
+       --disable-glibtest \
+       --disable-utf8 \
+       --without-slang \
+
+CONFIGURE_VARS += \
+       ac_cv_header_regex_h=no \
 
 define Package/nano/install    
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/nano $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))