[packages] nano: update to 2.2.5
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index cc5fe4dcb0a820f014475472a662333df73c01e1..2673b0ae520092047389bfda41074a8687583f67 100644 (file)
@@ -8,22 +8,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.2.2
+PKG_VERSION:=2.2.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
-PKG_MD5SUM:=7e3fa2c9877664f377372ef378b9f230
+PKG_MD5SUM:=77a10a49589f975ce98350a4527a2ebf
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nano
+  SUBMENU:=Editors
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
-  SUBMENU:=Editors
+  MAINTAINER:=Bernhard Loos <bernhardloos@googlemail.com>
+  DEPENDS:=+libncurses
 endef
 
 define Package/nano/description
@@ -42,7 +45,7 @@ CONFIGURE_VARS += \
 
 define Package/nano/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))