From: Joseph Roback <openwrt-devel@roback.cc>
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index 66df3cfb94f8b0db26c9744ceb6618cbf78a4cfb..3df856ee8315a84656ac898ef5b2927b438078b5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,22 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.2.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
-PKG_MD5SUM:=12eb7808ab1b8df4d20e87df22c38143
+PKG_MD5SUM:=77a10a49589f975ce98350a4527a2ebf
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nano
+  SUBMENU:=Editors
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
-  SUBMENU:=Editors
+  MAINTAINER:=Bernhard Loos <bernhardloos@googlemail.com>
+  DEPENDS:=+libncurses
 endef
 
 define Package/nano/description
@@ -42,7 +46,7 @@ CONFIGURE_VARS += \
 
 define Package/nano/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))