From: Joseph Roback <openwrt-devel@roback.cc>
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index b9e0751697f487b6c32b6cbc6f513696137a2d18..3df856ee8315a84656ac898ef5b2927b438078b5 100644 (file)
@@ -8,25 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.2.3
+PKG_VERSION:=2.2.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
-PKG_MD5SUM:=91918a484f54f94fedaebe00dc393a50
+PKG_MD5SUM:=77a10a49589f975ce98350a4527a2ebf
 
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nano
+  SUBMENU:=Editors
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
-  SUBMENU:=Editors
   MAINTAINER:=Bernhard Loos <bernhardloos@googlemail.com>
+  DEPENDS:=+libncurses
 endef
 
 define Package/nano/description
@@ -45,7 +46,7 @@ CONFIGURE_VARS += \
 
 define Package/nano/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))