[package] update nano to 2.1.9 (#4846)
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index aae02f344a5e00abb7d28b2256aef8a5baf23aab..4e4bcde453cfbac5d7c2b493011ec08c554ea80b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.0.6
+PKG_VERSION:=2.1.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.0
-PKG_MD5SUM:=619107f0fc3c4383d668cef15aa3ca32
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.1
+PKG_MD5SUM:=41e9ffb4a055eba666cdb17c4e50ba21
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,33 +24,26 @@ define Package/nano
   DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
+  SUBMENU:=Editors
 endef
 
 define Package/nano/description
-       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone 
+       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
        of the Pico text editor..
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-tiny \
-               --disable-glibtest \
-               --disable-utf8 \
-               --without-slang \
-               , \
-               ac_cv_header_regex_h=no \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-tiny \
+       --disable-glibtest \
+       --disable-utf8 \
+       --without-slang \
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += \
+       ac_cv_header_regex_h=no \
 
 define Package/nano/install    
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/nano $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))