[package] update loop-aes to 3.2h (#6277)
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index 9ac6cef5fc7d1672db471724f710a128c005d3df..996ebd66d31f037583d8b9f2bd5ed35d357b1762 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.0.7
+PKG_VERSION:=2.2.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.0
-PKG_MD5SUM:=16187fed2bdefec6275ece6401ce4cd2
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
+PKG_MD5SUM:=b34ea8fac9563b0485f39a065b5893bf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,12 +23,12 @@ define Package/nano
   DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
-  SUBMENU:=editors
+  SUBMENU:=Editors
 endef
 
 define Package/nano/description
-       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
-       of the Pico text editor..
+  GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
+  of the Pico text editor.
 endef
 
 CONFIGURE_ARGS += \
@@ -41,7 +40,7 @@ CONFIGURE_ARGS += \
 CONFIGURE_VARS += \
        ac_cv_header_regex_h=no \
 
-define Package/nano/install    
+define Package/nano/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef