[Packages] utils/nano:
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index 5dfa194a860a2540066dced0451c8af15071619e..9ac6cef5fc7d1672db471724f710a128c005d3df 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.0.6
+PKG_VERSION:=2.0.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.0
-PKG_MD5SUM:=619107f0fc3c4383d668cef15aa3ca32
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=16187fed2bdefec6275ece6401ce4cd2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,30 +28,22 @@ define Package/nano
 endef
 
 define Package/nano/description
-       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone 
+       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
        of the Pico text editor..
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-tiny \
-               --disable-glibtest \
-               --disable-utf8 \
-               --without-slang \
-               , \
-               ac_cv_header_regex_h=no \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-tiny \
+       --disable-glibtest \
+       --disable-utf8 \
+       --without-slang \
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += \
+       ac_cv_header_regex_h=no \
 
 define Package/nano/install    
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/nano $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))