[packages] nano: update to 2.2.3
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index 9c18600c0ffbf33ac07669d47d64b62bd739c907..aa73cc3164bda19dcc5bb635b5ecd80da87d39d5 100644 (file)
@@ -1,25 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=1.3.8
+PKG_VERSION:=2.2.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.ewtoo.org/~astyanax/nano/dist/v1.3 \
-       http://www.nano-editor.org/dist/v1.3
-PKG_MD5SUM:=20633397bf5d462255f37dfcc7cad4e7
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
+PKG_MD5SUM:=91918a484f54f94fedaebe00dc393a50
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,32 +24,27 @@ define Package/nano
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
-  DESCRIPTION:=\
-       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone \\\
-       of the Pico text editor..
   URL:=http://www.nano-editor.org/
+  SUBMENU:=Editors
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-tiny \
-               --disable-glibtest \
-               --disable-utf8 \
-               --without-slang \
-               , \
-               ac_cv_header_regex_h=no \
-       )
+define Package/nano/description
+  GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
+  of the Pico text editor.
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --enable-tiny \
+       --disable-glibtest \
+       --disable-utf8 \
+       --without-slang \
+
+CONFIGURE_VARS += \
+       ac_cv_header_regex_h=no \
 
-define Package/nano/install    
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/nano $(1)/usr/bin/
+define Package/nano/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))