[packages] ink: update to 0.5.1
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index 0861ae5e34c84a022adfca5e6e48c17820413e96..b9e0751697f487b6c32b6cbc6f513696137a2d18 100644 (file)
@@ -1,20 +1,21 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.0.7
+PKG_VERSION:=2.2.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.0
-PKG_MD5SUM:=16187fed2bdefec6275ece6401ce4cd2
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
+PKG_MD5SUM:=91918a484f54f94fedaebe00dc393a50
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,11 +26,12 @@ define Package/nano
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
   SUBMENU:=Editors
+  MAINTAINER:=Bernhard Loos <bernhardloos@googlemail.com>
 endef
 
 define Package/nano/description
-       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
-       of the Pico text editor..
+  GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
+  of the Pico text editor.
 endef
 
 CONFIGURE_ARGS += \
@@ -41,9 +43,9 @@ CONFIGURE_ARGS += \
 CONFIGURE_VARS += \
        ac_cv_header_regex_h=no \
 
-define Package/nano/install    
+define Package/nano/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))