[packages] ntfs-3g: update to 2010.8.8
[openwrt/svn-archive/archive.git] / utils / ntfs-3g / Makefile
index 56aa548ccfdd219742b88db2b2e1f26bc71a5d36..403fb9b54a6a086c469bebaaa547be132a753cbe 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntfs-3g
-PKG_RELEASE:=4
+PKG_RELEASE:=1
 
-PKG_VERSION:=2010.5.22
+PKG_VERSION:=2010.8.8
 
 ## 2010.3.6 needs a recent uclibc 0.9.30.2 or greater
 ## this has been fixed in 2010.5.16, keeping this in case this happens again
@@ -26,6 +26,7 @@ PKG_MD5SUM_2010.1.16:=e104c914e8d7d29ee83e63d46afbba25
 PKG_MD5SUM_2010.3.6:=12ce21aa044c6068a4df6e8cbd3c5cfa
 PKG_MD5SUM_2010.5.16:=aeff7659a4943c9223d79116f051a863
 PKG_MD5SUM_2010.5.22:=caa08c73220a7106c76f697b7a7915ec
+PKG_MD5SUM_2010.8.8:=6c109746c2708f679725a2ea441c61c6
 PKG_MD5SUM:=$(PKG_MD5SUM_$(PKG_VERSION))
 
 PKG_FIXUP:=libtool
@@ -50,8 +51,7 @@ endef
 
 define Package/ntfs-3g
   $(call Package/ntfs-3g/common)
-  DEPENDS:= +kmod-fuse +PACKAGE_NTFS-3G_USE_LIBFUSE:libfuse
-  DEPENDS+= +libpthread
+  DEPENDS+= +kmod-fuse +PACKAGE_NTFS-3G_USE_LIBFUSE:libfuse +libpthread
 endef
 
 define Package/ntfs-3g/description
@@ -70,7 +70,6 @@ endef
 define Package/ntfs-3g/config
 config PACKAGE_NTFS-3G_USE_LIBFUSE
        bool "use external FUSE library, selects package libfuse"
-       default n
        depends on PACKAGE_ntfs-3g
        ---help---
        Ntfs-3g by default uses a minimalized lite version of FUSE.
@@ -83,7 +82,6 @@ endef
 define Package/ntfs-3g-utils
   $(call Package/ntfs-3g/common)
   TITLE:=ntfs-3g utilities (ntfs-3g.secaudit, ntfs-3g.usermap)
-  DEFAULT:=n
   DEPENDS+= +ntfs-3g
 endef
 
@@ -100,7 +98,6 @@ endef
 define Package/mount.ntfs-3g
   $(call Package/ntfs-3g/common)
   TITLE:=ntfs-3g mount helper
-  DEFAULT:=y
   DEPENDS+= +ntfs-3g
 endef