cleanup Makefile and enable DRI/DRM
[openwrt/svn-archive/archive.git] / utils / ntfs-3g / Makefile
index 63508352927a516da11ff53c13d8c4d75d765f10..df102ba4844a74f3b97387f6710632cb52671f4b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntfs-3g
-PKG_VERSION:=1.616
-PKG_RELEASE:=2
+PKG_VERSION:=1.2531
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.ntfs-3g.org/
-PKG_MD5SUM:=fdb1c55f00263c962a52d0707a6d075e
+PKG_MD5SUM:=69374cd09803c5fdbb5dabd1d704b9fe
 
 PKG_BUILD_DEPENDS:=libfuse
 
@@ -22,10 +22,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ntfs-3g
   TITLE:=NTFS-3G
-  DEPENDS:=+libfuse +fuse-utils
+  DEPENDS:=+libfuse +fuse-utils +libpthread
   SECTION:=utils
   CATEGORY:=Utilities
   URL:=http://www.ntfs-3g.org
+  SUBMENU:=filesystem
 endef
 
 define Package/ntfs-3g/description
@@ -35,6 +36,7 @@ endef
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --with-fuse=external \
        , \
        ac_cv_path_LDCONFIG=""
 
@@ -53,20 +55,11 @@ define Build/InstallDev
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/ntfs-3g \
-               $(STAGING_DIR)/usr/lib/libntfs-3g.{a,so*}
-endef
-
 define Package/ntfs-3g/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,ntfs-3g))
-
-$(eval $(call RequireCommand,pkg-config, \
-       $(PKG_NAME) requires pkg-config. \
-))