[patchteam] sysfsutils: separate libsysfs and sysfsutils and move to libs, add patch...
[openwrt/svn-archive/archive.git] / utils / owfs / Makefile
index 27cdb803a26c391bca5df7c3b3988eb5032887d9..09b2c9b6bb6399689d51b39e54e1e3c900bf4fc3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,32 +7,49 @@
 
 include $(TOPDIR)/rules.mk
 PKG_NAME:=owfs
-PKG_VERSION:=2.7p13
+PKG_VERSION:=2.7p21
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=285483508f7fa42af3500b04f792058c
+PKG_MD5SUM:=8aea6f3bb0dc9fdb52ed3f0e9d84fa79
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-
 #
 # templates
 #
 
-define Package/owfs/Default
+define Package/$(PKG_NAME)/Default
   TITLE:=OWFS (1-Wire File System)
   URL:=http://owfs.sourceforge.net/
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Filesystem
 endef
 
-define Package/owfs/Server
-  $(call Package/owfs/Default)
+define Package/$(PKG_NAME)/Default/description
+  OWFS is a suite of programs that designed to make the 1-wire bus and its 
+  devices easily accessible. The underlying priciple is to create a virtual 
+  filesystem, with the unique ID being the directory, and the individual 
+  properties of the device are represented as simple files that can be read 
+  and written.
+
+  Details of the individual slave or master design are hidden behind a 
+  consistent interface. The goal is to provide an easy set of tools for a 
+  software designer to create monitoring or control applications. There are 
+  some performance enhancements in the implementation, including data caching, 
+  parallel access to bus masters, and aggregation of device communication. 
+  Still the fundemental goal has been ease of use, flexibility and correctness 
+  rather than speed.
+endef
+
+define Package/owfs-server
+  $(call Package/$(PKG_NAME)/Default)
   DEPENDS:=+libow +libpthread
-  SECTION:=net
-  CATEGORY:=Network
 endef
 
 define Package/owfs/Library
@@ -48,7 +65,7 @@ define Package/owfs/Utility
   DEPENDS:=+libow
 endef
 
-define Package/owfs/ServerInstall
+define Package/owfs-server/Install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $(1)/usr/bin/
 endef
@@ -64,12 +81,23 @@ define Package/libow
   TITLE:=OWFS - common shared library
 endef
 
+define Package/libow/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS library.
+endef
+
 define Package/libow-capi
   $(call Package/owfs/Library)
   DEPENDS:=+libow
   TITLE:=OWFS - C-API library
 endef
 
+define Package/libow-capi/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS C-API library.
+endef
 
 #
 # utilities
@@ -80,35 +108,61 @@ define Package/owshell
   TITLE:=OWFS - shell utilities
 endef
 
+define Package/owshell/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS shell utilities.
+endef
+
 define Package/owfs
   $(call Package/owfs/Utility)
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS+=+kmod-fuse +libfuse +fuse-utils
+  # libfuse depends on kmod-fuse, no need to declare dependency
+  DEPENDS+= +libfuse +fuse-utils
   TITLE:=OWFS - fuse file system
 endef
 
+define Package/owfs/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS fuse filesystem.
+endef
 
 #
 # network daemons
 #
 
 define Package/owhttpd
-  $(call Package/owfs/Server)
+  $(call Package/owfs-server)
   TITLE:=OWFS - http server
 endef
 
+define Package/owhttpd/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS http server.
+endef
+
 define Package/owftpd
-  $(call Package/owfs/Server)
+  $(call Package/owfs-server)
   TITLE:=OWFS - ftp server
 endef
 
+define Package/owftpd/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS ftp server.
+endef
+
 define Package/owserver
-  $(call Package/owfs/Server)
+  $(call Package/owfs-server)
   TITLE:=OWFS - network server
 endef
 
-
+define Package/owserver/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS network server.
+endef
 
 PKG_CONFIGURE_OPTS:= \
                --enable-zero \
@@ -140,27 +194,21 @@ define Build/Configure
                rm -rf config.{status,cache} ; \
                ./bootstrap ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) $(CFLAGS_LARGEFILE)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(TOOLCHAIN_DIR)/usr/lib -L$(TOOLCHAIN_DIR)/lib" \
-               lt_sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
-               lt_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -Wl,-rpath-link=$(TOOLCHAIN_DIR)/usr/lib" \
+               lt_cv_sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
                shrext_cmds=".so" \
                ./configure \
                        $(CONFIGURE_ARGS) \
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/include
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/{owcapi,owfs_config}.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow-*.so* $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so* $(STAGING_DIR)/usr/lib/
 endef
 
@@ -186,15 +234,15 @@ endef
 
 
 define Package/owserver/install
-       $(call Package/owfs/ServerInstall,$(1),owserver,70)
+       $(call Package/owfs-server/Install,$(1),owserver,70)
 endef
 
 define Package/owhttpd/install
-       $(call Package/owfs/ServerInstall,$(1),owhttpd,80)
+       $(call Package/owfs-server/Install,$(1),owhttpd,80)
 endef
 
 define Package/owftpd/install
-       $(call Package/owfs/ServerInstall,$(1),owftpd,80)
+       $(call Package/owfs-server/Install,$(1),owftpd,80)
 endef