[packages] owfs: sanitize Makefile:
[openwrt/svn-archive/archive.git] / utils / owfs / Makefile
index 09b2c9b6bb6399689d51b39e54e1e3c900bf4fc3..2e58418f9020f07470272abea0b640caa8701e4e 100644 (file)
@@ -1,14 +1,15 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
+
 PKG_NAME:=owfs
 PKG_VERSION:=2.7p21
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -47,8 +48,8 @@ define Package/$(PKG_NAME)/Default/description
   rather than speed.
 endef
 
-define Package/owfs-server
-  $(call Package/$(PKG_NAME)/Default)
+define Package/owfs/Server
+  $(call Package/owfs/Default)
   DEPENDS:=+libow +libpthread
 endef
 
@@ -65,12 +66,6 @@ define Package/owfs/Utility
   DEPENDS:=+libow
 endef
 
-define Package/owfs-server/Install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $(1)/usr/bin/
-endef
-
-
 #
 # shared libraries
 #
@@ -132,7 +127,7 @@ endef
 #
 
 define Package/owhttpd
-  $(call Package/owfs-server)
+  $(call Package/owfs/Server)
   TITLE:=OWFS - http server
 endef
 
@@ -143,7 +138,7 @@ define Package/owhttpd/description
 endef
 
 define Package/owftpd
-  $(call Package/owfs-server)
+  $(call Package/owfs/Server)
   TITLE:=OWFS - ftp server
 endef
 
@@ -154,7 +149,7 @@ define Package/owftpd/description
 endef
 
 define Package/owserver
-  $(call Package/owfs-server)
+  $(call Package/owfs/Server)
   TITLE:=OWFS - network server
 endef
 
@@ -164,61 +159,44 @@ define Package/owserver/description
   This package contains the OWFS network server.
 endef
 
-PKG_CONFIGURE_OPTS:= \
-               --enable-zero \
-               --disable-parport \
-               --disable-ownfsd \
-               --disable-ownet \
-               --disable-owpython \
-               --disable-libow-perl \
-               --disable-owphp \
-               --disable-owtcl \
-               --disable-owside \
-               --disable-swig
-
 CONFIGURE_ARGS += \
-       --prefix=/usr \
-       --exec-prefix=/usr \
        --enable-owftpd \
        --enable-owserver \
        --enable-owhttpd \
        --enable-owfs \
        --with-fuseinclude="$(STAGING_DIR)/usr/include" \
        --with-fuselib="$(STAGING_DIR)/usr/lib" \
-       $(PKG_CONFIGURE_OPTS) \
        --enable-shared \
-       --disable-rpath
+       --disable-rpath \
+       --enable-zero \
+       --disable-parport \
+       --disable-ownfsd \
+       --disable-ownet \
+       --disable-owpython \
+       --disable-libow-perl \
+       --disable-owphp \
+       --disable-owtcl \
+       --disable-owside \
+       --disable-swig \
+
+CONFIGURE_VARS += \
+       LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -Wl,-rpath-link=$(TOOLCHAIN_DIR)/usr/lib" \
+       lt_cv_sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+       lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+       shrext_cmds=".so" \
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               rm -rf config.{status,cache} ; \
-               ./bootstrap ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -Wl,-rpath-link=$(TOOLCHAIN_DIR)/usr/lib" \
-               lt_cv_sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
-               lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
-               shrext_cmds=".so" \
-               ./configure \
-                       $(CONFIGURE_ARGS) \
-       );
+       (cd $(PKG_BUILD_DIR); ./bootstrap)
+       $(call Build/Configure/Default)
 endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR)/usr/include
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/{owcapi,owfs_config}.h $(STAGING_DIR)/usr/include/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/include/ow{capi,fs_config}.h $(STAGING_DIR)/usr/include/
        $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow-*.so* $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so* $(STAGING_DIR)/usr/lib/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow{,capi}*.{a,so*} $(STAGING_DIR)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/{libow-capi,owfs_config}.h \
-               $(STAGING_DIR)/usr/lib/libow-capi-*.so* \
-               $(STAGING_DIR)/usr/lib/libow-*.so*
-endef
-
-
 define Package/owfs/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owfs $(1)/usr/bin/
@@ -226,6 +204,7 @@ endef
 
 define Package/owshell/install
        $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owget $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owread $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owwrite $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owdir $(1)/usr/bin/
@@ -234,15 +213,18 @@ endef
 
 
 define Package/owserver/install
-       $(call Package/owfs-server/Install,$(1),owserver,70)
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owserver $(1)/usr/bin/
 endef
 
 define Package/owhttpd/install
-       $(call Package/owfs-server/Install,$(1),owhttpd,80)
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owhttpd $(1)/usr/bin/
 endef
 
 define Package/owftpd/install
-       $(call Package/owfs-server/Install,$(1),owftpd,80)
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owftpd $(1)/usr/bin/
 endef
 
 
@@ -254,8 +236,6 @@ endef
 define Package/libow-capi/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so.* $(1)/usr/lib/
-       #$(INSTALL_DIR) $(1)/usr/include
-       #$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/{owcapi,owfs_config}.h $(1)/usr/include/
 endef