[packages] pciutils: Fix missing parenthesis typo (#5694)
[openwrt/svn-archive/archive.git] / utils / pciutils / Makefile
index fb3add22bafa0b14d08fe5a24b4a6ea26021052e..4160919d61f8c20f933323a9c9269243dbd95a9b 100644 (file)
@@ -1,25 +1,20 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=2.2.1
-PKG_RELEASE:=1
+PKG_VERSION:=3.1.2
+PKG_RELEASE:=2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils \
        ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=46387fd7a18c33fbb5311fdb3ab9ea12
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,24 +22,38 @@ define Package/pciutils
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
-  DESCRIPTION:=Linux PCI Utilities.\\\
-    This package contains various utilities for inspecting and setting of \\\
-    devices connected to the PCI bus.
-  URL:=http://www.kernel.org/pub/software/utils/pciutils/
+  URL:=http://mj.ucw.cz/pciutils.shtml
+endef
+
+define Package/pciutils/description
+       This package contains various utilities for inspecting and setting of
+       devices connected to the PCI bus.
 endef
 
-define Build/Configure
+define Package/pciutils/postinst
+#!/bin/sh
+(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids.sh)
+exit 0
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       IDSDIR="/usr/share" \
+       HOST="$(GNU_TARGET_NAME)" \
+       ZLIB="no" \
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include/pci
+       $(CP) $(foreach i,pci.h config.h header.h types.h, \
+               $(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci
 endef
 
 define Package/pciutils/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/{lspci,setpci} $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
 endef