Upgrade pciutils to 3.0.0 (#3689)
[openwrt/svn-archive/archive.git] / utils / pciutils / Makefile
index 8e561be0c373f0494c6b097ded56bd5f2e54ec42..5301bb7d830f539bbc8af4a2b2256a0a883618aa 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=2.2.1
+PKG_VERSION:=3.0.0
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
        ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=85b5dae042217cf11bca10d52210a78d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,27 +23,37 @@ define Package/pciutils
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
-  DESCRIPTION:=\
-       This package contains various utilities for inspecting and setting of \\\
+  URL:=http://mj.ucw.cz/pciutils.shtml
+endef
+
+define Package/pciutils/description
+       This package contains various utilities for inspecting and setting of
        devices connected to the PCI bus.
-  URL:=http://www.kernel.org/pub/software/utils/pciutils/
 endef
 
-define Build/Configure
+define Package/pciutils/postinst
+#!/bin/sh
+$${IPKG_INSTROOT}/usr/sbin/update-pciids.sh
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               IDSDIR="/usr/share" \
-               HOST="$(GNU_TARGET_NAME)" \
-       )
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       IDSDIR="/usr/share" \
+       HOST="$(GNU_TARGET_NAME)" \
+       ZLIB="no" \
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include/pci
+       $(CP) $(foreach i,pci.h config.h header.h types.h, \
+               $(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci
 endef
 
 define Package/pciutils/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/{lspci,setpci} $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
 endef