massive Makefile cleanup, add missing 'svn:keywords' property
[openwrt/svn-archive/archive.git] / utils / pciutils / Makefile
index 724f2b0a2e307b431508728d72788e0e3e8aa95d..8e561be0c373f0494c6b097ded56bd5f2e54ec42 100644 (file)
@@ -12,13 +12,13 @@ PKG_NAME:=pciutils
 PKG_VERSION:=2.2.1
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
        ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
 PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -27,9 +27,9 @@ define Package/pciutils
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
-  DESCRIPTION:=Linux PCI Utilities.\\\
-    This package contains various utilities for inspecting and setting of \\\
-    devices connected to the PCI bus.
+  DESCRIPTION:=\
+       This package contains various utilities for inspecting and setting of \\\
+       devices connected to the PCI bus.
   URL:=http://www.kernel.org/pub/software/utils/pciutils/
 endef
 
@@ -37,7 +37,11 @@ define Build/Configure
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default, CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME))
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               IDSDIR="/usr/share" \
+               HOST="$(GNU_TARGET_NAME)" \
+       )
 endef
 
 define Package/pciutils/install