[packages] pciutils: update to 3.1.6
[openwrt/svn-archive/archive.git] / utils / pciutils / Makefile
index 7b12360c0baceab331196f6574544558b1195c10..a4d534fae5d3de17129818ad7d6628d08af0a4f4 100644 (file)
@@ -1,25 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=2.2.1
+PKG_VERSION:=3.1.6
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
-       ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
+PKG_MD5SUM:=1d183851f68abd6c918a5c1852576ad6
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,25 +23,40 @@ define Package/pciutils
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
-  DESCRIPTION:=Linux PCI Utilities.\\\
-    This package contains various utilities for inspecting and setting of \\\
-    devices connected to the PCI bus.
-  URL:=http://www.kernel.org/pub/software/utils/pciutils/
+  URL:=http://mj.ucw.cz/pciutils.shtml
+  DEPENDS:=+zlib
+endef
+
+define Package/pciutils/description
+       This package contains various utilities for inspecting and setting of
+       devices connected to the PCI bus.
 endef
 
-define Build/Configure
+define Package/pciutils/postinst
+#!/bin/sh
+(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids)
+exit 0
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       PREFIX="/usr" \
+       HOST="$(GNU_TARGET_NAME)" \
+       ZLIB="yes" \
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include/pci
+       $(CP) $(foreach i,pci.h config.h header.h types.h, \
+               $(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci
 endef
 
 define Package/pciutils/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/{lspci,setpci} $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share
-       $(CP) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{lspci,setpci,update-pciids} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/share
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/pci.ids.gz $(1)/usr/share/
 endef
 
 $(eval $(call BuildPackage,pciutils))