[Packages] utils/pciutils:
[openwrt/svn-archive/archive.git] / utils / pciutils / Makefile
index c2b112257539e655dab19329ec264afab3353b3a..d20f2f56ae33a6a0cb61784f54f665fc8c86bf4a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.2.9
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
        ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=cec05e7785497c5e19da2f114b934ffd
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,11 +23,11 @@ define Package/pciutils
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
-  URL:=http://www.kernel.org/pub/software/utils/pciutils/
+  URL:=http://mj.ucw.cz/pciutils.shtml
 endef
 
 define Package/pciutils/description
-       This package contains various utilities for inspecting and setting of 
+       This package contains various utilities for inspecting and setting of
        devices connected to the PCI bus.
 endef
 
@@ -38,25 +36,18 @@ define Package/pciutils/postinst
 $${IPKG_INSTROOT}/usr/sbin/update-pciids.sh
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               IDSDIR="/usr/share" \
-               HOST="$(GNU_TARGET_NAME)" \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       IDSDIR="/usr/share" \
+       HOST="$(GNU_TARGET_NAME)" \
+       ZLIB="no" \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/include/pci
-       $(CP) $(PKG_BUILD_DIR)/lib/pci.h $(1)/usr/include/pci
-       $(CP) $(PKG_BUILD_DIR)/lib/config.h $(1)/usr/include/pci
-       $(CP) $(PKG_BUILD_DIR)/lib/header.h $(1)/usr/include/pci
-       $(CP) $(PKG_BUILD_DIR)/lib/types.h $(1)/usr/include/pci
+       $(CP) $(foreach i,pci.h config.h header.h types.h, \
+               $(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci
 endef
 
 define Package/pciutils/install