utils/picocom: update picocom to version 1.6 (closes #7873)
[openwrt/svn-archive/archive.git] / utils / picocom / Makefile
index e91ef3aa042b0f22a9e9b153470f72c5c68bc99a..0cd0c50ce6d6fbf03ba47ac2da59051f203eb9e2 100644 (file)
@@ -1,22 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=picocom
-PKG_VERSION:=1.4
+PKG_VERSION:=1.6
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://efault.net/npat/hacks/picocom/dist/
-PKG_MD5SUM:=08fcc5f6bb9e7676a2569386d5ea9f70
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://picocom.googlecode.com/files
+PKG_MD5SUM:=426c3d30b82cbc80b0dafdccd6020c6c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,15 +21,18 @@ define Package/picocom
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=A minimal dumb-terminal emulation program
-  DESCRIPTION:=A minimal dumb-terminal emulation program.\\\
-    As its name suggests, picocom is a minimal dumb-terminal emulation \\\
-    program. It is, in principle, very much like minicom, only it's pico \\\
-    instead of mini! It was designed to serve as a simple, manual, modem \\\
-    configuration, testing, and debugging tool. It has also served (quite \\\
-    well) as a low-tech "terminal-window" to allow operator intervention \\\
-    in PPP connection scripts. It could also prove useful in many other \\\
-    similar tasks.
-  URL:=http://efault.net/npat/hacks/picocom/
+  URL:=http://code.google.com/p/picocom/
+  SUBMENU:=Terminal
+endef
+
+define Package/picocom/description
+       As its name suggests, picocom is a minimal dumb-terminal emulation 
+       program. It is, in principle, very much like minicom, only it's pico 
+       instead of mini! It was designed to serve as a simple, manual, modem 
+       configuration, testing, and debugging tool. It has also served (quite 
+       well) as a low-tech "terminal-window" to allow operator intervention 
+       in PPP connection scripts. It could also prove useful in many other 
+       similar tasks.
 endef
 
 define Build/Configure
@@ -41,14 +41,14 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-               CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                picocom
 endef
 
 define Package/picocom/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,picocom))