[packages] minicom, microcom, picocom, setserial: s/terminal/Terminal/ for submenu...
[openwrt/svn-archive/archive.git] / utils / picocom / Makefile
index 754d53ab664a938c9a36034f6aeba91685452bea..21cc4e54824dfa1e49c20021984fd73e5ef04868 100644 (file)
@@ -1,10 +1,9 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,11 +12,8 @@ PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://efault.net/npat/hacks/picocom/dist/
+PKG_SOURCE_URL:=http://picocom.googlecode.com/files
 PKG_MD5SUM:=08fcc5f6bb9e7676a2569386d5ea9f70
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,7 +21,8 @@ define Package/picocom
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=A minimal dumb-terminal emulation program
-  URL:=http://efault.net/npat/hacks/picocom/
+  URL:=http://code.google.com/p/picocom/
+  SUBMENU:=Terminal
 endef
 
 define Package/picocom/description
@@ -44,8 +41,8 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                picocom
 endef