replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / utils / picocom / Makefile
index e91ef3aa042b0f22a9e9b153470f72c5c68bc99a..5730d52189d78fafa35d6b54d1351be8cd2c0cef 100644 (file)
@@ -12,26 +12,27 @@ PKG_NAME:=picocom
 PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://efault.net/npat/hacks/picocom/dist/
 PKG_MD5SUM:=08fcc5f6bb9e7676a2569386d5ea9f70
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/picocom
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=A minimal dumb-terminal emulation program
-  DESCRIPTION:=A minimal dumb-terminal emulation program.\\\
-    As its name suggests, picocom is a minimal dumb-terminal emulation \\\
-    program. It is, in principle, very much like minicom, only it's pico \\\
-    instead of mini! It was designed to serve as a simple, manual, modem \\\
-    configuration, testing, and debugging tool. It has also served (quite \\\
-    well) as a low-tech "terminal-window" to allow operator intervention \\\
-    in PPP connection scripts. It could also prove useful in many other \\\
-    similar tasks.
+  DESCRIPTION:=\
+       As its name suggests, picocom is a minimal dumb-terminal emulation \\\
+       program. It is, in principle, very much like minicom, only it's pico \\\
+       instead of mini! It was designed to serve as a simple, manual, modem \\\
+       configuration, testing, and debugging tool. It has also served (quite \\\
+       well) as a low-tech "terminal-window" to allow operator intervention \\\
+       in PPP connection scripts. It could also prove useful in many other \\\
+       similar tasks.
   URL:=http://efault.net/npat/hacks/picocom/
 endef
 
@@ -41,14 +42,14 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-               CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                picocom
 endef
 
 define Package/picocom/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,picocom))