[package] lvm2: add new mirror and fix shared library installation
[openwrt/svn-archive/archive.git] / utils / pipacs / Makefile
index a79e6705382b392a3141b83ad9c35fc9ddedf7d0..5d1b08f6342769e1b67b09f6625f76a65e6a4173 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -21,19 +20,18 @@ define Package/pipacs
   TITLE:=UNIX socket accounting/wiewer program
 endef
 
-define Build/Prepare   
-       mkdir -p $(PKG_BUILD_DIR)
+define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                all
 endef
 
-define Package/pipacs/install  
+define Package/pipacs/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/pipacs $(1)/usr/bin/
 endef