replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / utils / procmail / Makefile
index efe9ec67cf84f7c8a60df911ef1f7472f5f66d71..3e1a322480ae55fcf35a9bc6b75b0b3810bdcb62 100644 (file)
@@ -24,20 +24,21 @@ include $(INCLUDE_DIR)/package.mk
 define Package/procmail
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=mail processing tool
-  DESCRIPTION:=Procmail is able to process and classify incoming mail into\\\
+  TITLE:=Mail processing tool
+  DESCRIPTION:=\
+       Procmail is able to process and classify incoming mail into \\\
        different mail boxes.\\\
-       Very useful in conjunction with mutt.\\\
+       Very useful in conjunction with mutt.
   URL:=http://www.procmail.org
 endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src -f ../Makefile.openwrt  \
-               CC=$(TARGET_CC)
+               $(TARGET_CONFIGURE_OPTS)
 endef
 
 define Package/procmail/install
-       mkdir -p $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/procmail $(1)/usr/bin/ 
        $(CP) $(PKG_BUILD_DIR)/src/formail $(1)/usr/bin/
 endef