cleanup Makefile, extract image-data, add init-script, replace generic image with...
[openwrt/svn-archive/archive.git] / utils / psplash / Makefile
index 8c9a508135b08b9e0d38ede5fd1417fc5f4a3ccd..c737c7c3201cfd2d9d543dcb6f1b2a53f707f56b 100644 (file)
@@ -15,6 +15,10 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://projects.o-hand.com/sources/psplash/
 PKG_MD5SUM:=7649b7e0fac573eca2048a2a267e242b
 
 PKG_SOURCE_URL:=http://projects.o-hand.com/sources/psplash/
 PKG_MD5SUM:=7649b7e0fac573eca2048a2a267e242b
 
+PKG_INSTALL:=1
+
+IMAGE_FILE:=generic
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/psplash
 include $(INCLUDE_DIR)/package.mk
 
 define Package/psplash
@@ -29,20 +33,21 @@ define Package/psplash/description
 PSplash is a userspace graphical boot splash screen.
 endef
 
 PSplash is a userspace graphical boot splash screen.
 endef
 
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Build/Configure
+       $(CP) \
+               ./files/image_$(IMAGE_FILE).h \
+               $(PKG_BUILD_DIR)/psplash-owrt-img.h
+       $(call Build/Configure/Default)
 endef
 
 define Package/psplash/install
 endef
 
 define Package/psplash/install
-       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_DIR) $(1)/bin $(1)/etc/init.d
        $(CP) \
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/bin/psplash \
-               $(PKG_INSTALL_DIR)/usr/bin/psplash-write \
+               $(PKG_INSTALL_DIR)/usr/bin/psplash* \
                $(1)/bin/
                $(1)/bin/
+       $(INSTALL_BIN) \
+               ./files/init \
+               $(1)/etc/init.d/psplash
 endef
 
 endef
 
-
 $(eval $(call BuildPackage,psplash))
 $(eval $(call BuildPackage,psplash))