[packages] collectd: remove redundant build dependencies
[openwrt/svn-archive/archive.git] / utils / rdiff-backup / Makefile
index 537ee20e1499d3524d5421c54c513d541ca8e462..046bc19d07fc3143cb97a7fabbd9addf2bfe30e0 100644 (file)
@@ -1,33 +1,41 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
  
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rdiff-backup
-PKG_VERSION:=1.0.4
+PKG_VERSION:=1.0.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://savannah.nongnu.org/download/rdiff-backup/
-PKG_MD5SUM:=756b38aaf2602d097cafd08996fb7887
+PKG_MD5SUM:=fa2a165fa07a94be52c52e3545bc7758
+
+PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
-define PyPackage/rdiff-backup
-  SECTION:=utils
-  CATEGORY:=Utilities
+define Package/rdiff-backup
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
   TITLE:=Incremental backup utility
   URL:=http://www.nongnu.org/rdiff-backup
-  DEPENDS+= +librsync
+  DEPENDS:=+python-mini +librsync +libpopt
+endef
+
+define Package/rdiff-backup/description
+       rdiff-backup backs up one directory to another, possibly over a
+       network. The target directory ends up a copy of the source directory,
+       but extra reverse diffs are stored in a special subdirectory of that
+       target directory, so you can still recover files lost some time ago.
+       The idea is to combine the best features of a mirror and an incremental
+       backup.
 endef
 
 define PyPackage/rdiff-backup/filespec
@@ -36,6 +44,7 @@ define PyPackage/rdiff-backup/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --librsync-dir="$(STAGING_DIR)/usr" , \
        )
@@ -45,3 +54,4 @@ define Build/Compile
 endef
 
 $(eval $(call PyPackage,rdiff-backup))
+$(eval $(call BuildPackage,rdiff-backup))