add libtool-fix
[openwrt/svn-archive/archive.git] / utils / rdiff-backup / Makefile
index 1b717df102e1208a886af9753fb22bd69d581a65..5a2fc01dcd7bf383cb8674b50b78cd3e47e22f6d 100644 (file)
@@ -9,20 +9,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rdiff-backup
-PKG_VERSION:=1.0.4
+PKG_VERSION:=1.0.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://savannah.nongnu.org/download/rdiff-backup/
-PKG_MD5SUM:=756b38aaf2602d097cafd08996fb7887
+PKG_MD5SUM:=fa2a165fa07a94be52c52e3545bc7758
 
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/rdiff-backup
   SUBMENU:=Python
@@ -33,12 +30,22 @@ define Package/rdiff-backup
   DEPENDS:=python-core +librsync +libpopt
 endef
 
+define Package/rdiff-backup/description
+       rdiff-backup backs up one directory to another, possibly over a
+       network. The target directory ends up a copy of the source directory,
+       but extra reverse diffs are stored in a special subdirectory of that
+       target directory, so you can still recover files lost some time ago.
+       The idea is to combine the best features of a mirror and an incremental
+       backup.
+endef
+
 define PyPackage/rdiff-backup/filespec
 +|/usr/bin/rdiff-backup
 +|$(PYTHON_PKG_DIR)/rdiff_backup
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --librsync-dir="$(STAGING_DIR)/usr" , \
        )