massive Makefile cleanup, add missing 'svn:keywords' property
[openwrt/svn-archive/archive.git] / utils / rrdcollect / Makefile
index 519d84d2c523058c929251a33e91cd9bc15df0f0..ca581ea95b6ae7a4fc8da645a5930cb6203fcfca 100644 (file)
@@ -11,46 +11,46 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=rrdcollect
 PKG_VERSION:=0.2.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=5e4305c612bc3cccbaf802c275c81a11
 
-PKG_SOURCE_URL:=@SF/rrdcollect
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/rrdcollect
+PKG_MD5SUM:=5e4305c612bc3cccbaf802c275c81a11
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-ifneq ($(BR2_PACKAGE_LIBRRD),)
-RRDTOOL_LIBS:=-lart_lgpl_2 -lfreetype -lpng
-endif
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rrdcollect
   SECTION:=utils
   CATEGORY:=Utilities
+  DESCRIPTION:=\
+       RRDcollect is a daemon which polls ceratin files in /proc/ \\\
+       directory, gathering data and storing it inside RRDtool's \\\
+       database files.  Being written in C should be both fast \\\
+       and resources-friendly.  Supports both scanf(3)-style \\\
+       pattern matches and perl compatible regular expressions.
+  URL:=http://rrdcollect.sourceforge.net/
+endef
+
+define Package/rrdcollect
+  $(call Package/rrdcollect/Default)
   DEPENDS:=+librrd1
   TITLE:=Round-Robin Database (RRD) collecting daemon
-  DESCRIPTION:=RRDcollect is a daemon which polls ceratin files in /proc/\\\
-       directory, gathering data and storing it inside RRDtool's\\\
-       database files.  Being written in C should be both fast\\\
-       and resources-friendly.  Supports both scanf(3)-style\\\
-       pattern matches and perl compatible regular expressions.\\\
-  URL:=http://rrdcollect.sourceforge.net/
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the RRD collecting daemon.
   MENU:=1
 endef
 
 define Package/rrdcollect-example
-  SECTION:=utils
-  CATEGORY:=Utilities
+  $(call Package/rrdcollect/Default)
   DEPENDS:=rrdcollect
   TITLE:=Example setup for RRD collecting daemon above
-  DESCRIPTION:=RRDcollect is a daemon which polls ceratin files in /proc/\\\
-        directory, gathering data and storing it inside RRDtool's\\\
-        database files.  Being written in C should be both fast\\\
-        and resources-friendly.  Supports both scanf(3)-style\\\
-        pattern matches and perl compatible regular expressions.\\\
-  URL:=http://rrdcollect.sourceforge.net/
+  DESCRIPTION+=\\\
+       \\\
+       This package contains examples for the RRD collecting daemon.
 endef
 
 define Package/rrdcollect-example/conffiles
@@ -68,18 +68,14 @@ define Build/Configure
                --without-rrdtool \
                --with-librrd \
                --without-libpcre \
-               --without-libpcap, \
+               --without-libpcap \
+               , \
                CFLAGS="$(TARGET_CFLAGS) -DSOCKET_COMM" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               LIBS="$(RRDTOOL_LIBS) -lz" \
-               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               LIBS="-lz" \
        )
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install