[package] update libmcrypt to 2.5.8 (#3602)
[openwrt/svn-archive/archive.git] / utils / rrdcollect / Makefile
index 4716d2a7035cc12bcf89c81be3d18fff75c1dfcf..cdc696d8aa0750b89c825e036daaa8b5a6617200 100644 (file)
@@ -4,33 +4,22 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rrdcollect
 PKG_VERSION:=0.2.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rrdcollect
 PKG_MD5SUM:=5e4305c612bc3cccbaf802c275c81a11
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rrdcollect/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DESCRIPTION:=\
-       RRDcollect is a daemon which polls ceratin files in /proc/ \\\
-       directory, gathering data and storing it inside RRDtool's \\\
-       database files.  Being written in C should be both fast \\\
-       and resources-friendly.  Supports both scanf(3)-style \\\
-       pattern matches and perl compatible regular expressions.
   URL:=http://rrdcollect.sourceforge.net/
 endef
 
@@ -38,18 +27,32 @@ define Package/rrdcollect
   $(call Package/rrdcollect/Default)
   DEPENDS:=+librrd
   TITLE:=Round-Robin Database (RRD) collecting daemon
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the RRD collecting daemon.
   MENU:=1
 endef
 
+define Package/rrdcollect/description
+=
+       RRDcollect is a daemon which polls ceratin files in /proc/ 
+       directory, gathering data and storing it inside RRDtool's 
+       database files. Being written in C should be both fast 
+       and resources-friendly. Supports both scanf(3)-style 
+       pattern matches and perl compatible regular expressions.        
+       This package contains the RRD collecting daemon.
+endef
+
 define Package/rrdcollect-example
   $(call Package/rrdcollect/Default)
   DEPENDS:=rrdcollect
   TITLE:=Example setup for RRD collecting daemon above
-  DESCRIPTION+=\\\
-       \\\
+endef
+
+define Package/rrdcollect-example/description
+=
+       RRDcollect is a daemon which polls ceratin files in /proc/ 
+       directory, gathering data and storing it inside RRDtool's 
+       database files. Being written in C should be both fast 
+       and resources-friendly. Supports both scanf(3)-style 
+       pattern matches and perl compatible regular expressions.        
        This package contains examples for the RRD collecting daemon.
 endef
 
@@ -70,7 +73,7 @@ define Build/Configure
                --without-libpcap \
                , \
                CFLAGS="$(TARGET_CFLAGS) -DSOCKET_COMM" \
-               LIBS="-lz" \
+               LIBS="-lz -lfreetype -lpng -lart_lgpl_2" \
        )
 endef
 
@@ -82,7 +85,7 @@ endef
 
 define Package/rrdcollect/install      
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/rrdcollect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rrdcollect $(1)/usr/sbin/
 endef
 
 define Package/rrdcollect-example/install