python packaging related cleanups for rdiff-backup and rrdtool
[openwrt/svn-archive/archive.git] / utils / rrdtool / Makefile
index 475f9a4132217d68a5b6f37689037e4990e7b68a..ecff3ff3de32f5594579d57d2700016f62dbb493 100644 (file)
@@ -21,9 +21,6 @@ PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/rrdtool/Default
   SECTION:=utils
@@ -94,6 +91,7 @@ else
 endif
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef