wshaper: stupid me, forget to create dirs
[openwrt/svn-archive/archive.git] / utils / scponly / Makefile
index ce6ec05343b6376c34f2e0349afd647e7dacc1e5..0e29bf40a1738a53c3392edbbb6fbad3efc0c510 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,20 +13,21 @@ PKG_VERSION:=4.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://sublimation.org/scponly
+PKG_SOURCE_URL:=@SF/scponly \
+       http://sublimation.org/scponly
 PKG_MD5SUM:=0425cb868cadd026851238452f1db907
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_CONFIGURE_OPTS:= \
-  --enable-winscp-compat \
-  --enable-scp-compat \
-  --disable-rsync-compat \
-  --without-sftp-server
-
+CONFIGURE_ARGS += \
+       ac_cv_path_scponly_PROG_SFTP_SERVER="/usr/libexec/sftp-server" \
+       , \
+       --enable-winscp-compat \
+       --enable-scp-compat \
+       --disable-rsync-compat \
+       --with-sftp-server="/usr/libexec/sftp-server"
 
 define Package/scponly
   SECTION:=utils