[package] update sdparm to 1.04 (#5963)
[openwrt/svn-archive/archive.git] / utils / sdparm / Makefile
index a113767be75517256f8e28ccab44d0b5a3bc2633..95c3857fc1577cd53408281e0c2b6a5306544a75 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,29 +8,34 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sdparm
-PKG_VERSION:=1.02
+PKG_VERSION:=1.04
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://sg.torque.net/sg/p/
-PKG_MD5SUM:=cc6de6fdba91f382d00b9b8a09dd14f2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://sg.danny.cz/sg/p
+PKG_MD5SUM:=f4b8c7bfc1cd27d30fbdc066a65a44ea
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sdparm
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=read or modify scsi or usb disk parameters
+  TITLE:=Read or modify SCSI or USB disk parameters
   DEPENDS:=+kmod-scsi-generic
+  SUBMENU:=disc
+  URL:=http://sg.danny.cz/sg/sdparm.html
 endef
 
 define Package/sdparm/description
-       The sdparm utility outputs and in some cases modifies SCSI device parameters.
+       The sdparm utility outputs and in some cases modifies SCSI device
+       parameters.
 endef
 
 define Package/sdparm/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/sdparm $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,sdparm))