Add a default configuration file (#1404)
[openwrt/svn-archive/archive.git] / utils / setpwc / Makefile
index b7cd10c8776206267138a786cb434c2f82fa9e5d..d795ec0a992c8ce5aeee9692301d20b6277332f1 100644 (file)
@@ -18,14 +18,12 @@ PKG_MD5SUM:=a125d76f630c4aab940df5912f161965
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/setpwc
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+kmod-pwc
   TITLE:=Philips (and compatibles) WebCams (PWC) control utility
   URL:=http://www.vanheusden.com/setpwc/
 endef
@@ -36,8 +34,8 @@ define Build/Compile
 endef
 
 define Package/setpwc/install  
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/setpwc $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/setpwc $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,setpwc))